Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: dSUG - Forum der deutschsprachigen Servoy User Group. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

EWI

Anfänger

  • »EWI« ist der Autor dieses Themas

Beiträge: 80

Wohnort: Feldkirch, Vorarlberg, Österreich

  • Private Nachricht senden

1

Donnerstag, 12. Mai 2016, 08:21

Smart-Client durch Proxy betreiben (Fehler: Connection to Servoy Server is invalid)

Hallo Forum,

meine Hauptapplication läuft in der MS-Azure-Cloud mit Servoy8. Die Kunden sind meist in die Domäne einer Stadt-, Bundesland- oder Kantonsverwaltung eingebunden. Es ist dann meist notwendig Anpassungen in deren Fireall zu veranlassen, um den Zugriff des Servoy-Smart-Clients zu erlauben. Bisher reichte mein Wissen dazu aus und mit ein, zwei Telefonaten lief es. Bei einem (wichtigen grossen Kunden) ist es dessen Administrator (mit Team) nicht gelungen den Servoy-Smart-Client durchzuschleussen. Die Firewall ist hier nicht das Problem sondern der Proxy-Server. D.h. auf den PC's der Administratoren kann der Proxy dekativert werden und der Servoy-Smart-Clint läuft (durch die Checkpoint-Firewall). Beim Anwender-PC muss der Proxy aktiv bleiben. Zu diesem Zweck wurden Proxy-Excludes (direkte Verbindungen zu einzelnen IP's) eingerichtet. Folgende Hosts werden derzeit nicht über Proxy geleitet:
- die IP der Application in der Azure-Cloud
- t2.symcb.com
- t1.symcd.com
die beiden letzten hat der Administrator rausgefunden, wird beim Serverzugriff aufgerufen, muss was mit der Zertifikatsprüfung von Servoy zu tun haben.

Frage: gibts eine Anleitung für eine Proxy-Installation ? (Dr. Google hat zwar einiges geliefert, bin daraus nicht schlau geworden)

Danke und Grüße
Roland

EWI

Anfänger

  • »EWI« ist der Autor dieses Themas

Beiträge: 80

Wohnort: Feldkirch, Vorarlberg, Österreich

  • Private Nachricht senden

2

Freitag, 13. Mai 2016, 08:05

Hallo Forum,

frei nach dem Sprichwort: "Probieren geht studieren", hab ne Lösung gefunden. In den Netzwerk Settings des Application Servers muss der SocketFactory.tunnelConnectionMode von 2waysocket auf http&socket umgestellt werden

SG Roland

Social Bookmarks

Thema bewerten