Du bist nicht angemeldet.

Gabriel

 Administrator

  • »Gabriel« ist der Autor dieses Themas

Beiträge: 199

Wohnort: Inwil LU (CH)

  • Private Nachricht senden

1

Donnerstag, 24. Februar 2011, 11:56

Konfiguration des DatabaseServer für MS-SQL-Server

Für all jene, die mit SQL-Server Datenbanken arbeiten wollen hier ein Tipp, wie der Server zu definieren ist.

Nehmen wir an, der SQL-Server heisst '\\MeinPC\SQLExpress' und die Datenbank 'MeineDatenbank', dann muss bei der URL der Servername und der Instanzname separat angegeben werden. Andernfalls funktioniert es nicht.

Beispiel URL: jdbc:sqlserver://MeinPC;instance=SQLExpress;DatabaseName=MeineDatenbank
Gabriel

2

Dienstag, 10. Mai 2011, 21:38

Treiber jtds / freetds mit SQLEXPRESS und benannter Instanz

Ergänzung zu Gabriels Info


für dieses Szenario sieht die Connection so aus:

URL: jdbc:jtds:sqlserver://localhost/<dbname>:1433;instance=<InstanzName>
Driver: net.sourceforge.jtds.jdbc.Driver

Zu Beachten ist hier der fest eingestellte Port 1433.
Dieser kann über den SQL Server Connection Manager für das TCP/IP Protokoll gestellt werden.
Dabei muss für die IP Adresse (hier 127.0.0.1) "TCP Dynamic Ports" ausgeschaltet werden (Die Null rausnehmen) und der feste Port eingestellt werden. Ohne den festen Port benutzt der SQL Server immer wieder andere Ports und Verbindungen kommen zumindest nicht sicher zustande.

hth

Joachim

3

Montag, 5. Dezember 2011, 16:06

Connection für Zugriff auf nicht-default Schema

Noch eine Ergänzung

falls der Zugriff auf ein Schema erfolgen soll, das nicht das default-Schema des benutzen Logins ist, dann klappt das (zumindest bei mir / auf einem SQL2008 Cluster) wie folgt:


  • URL+Treiber wie bereits beschrieben
  • Catalog auf <none> setzen (<empty> funktioniert nicht!)
  • unter Schema das gewünschte (z.B. dbo) eintragen

Das Login muss dabei natürlich für das gewünschte Schema ausreichende Rechte haben, sonst bleibt u.U. die Liste der Server Objekte komplett leer...

EWI

Anfänger

Beiträge: 80

Wohnort: Feldkirch, Vorarlberg, Österreich

  • Private Nachricht senden

4

Donnerstag, 7. September 2017, 18:42

SQL Express 2012

Hallo Gabriel,

auf Grund Deines Beitrages vermute/hoffe ich, dass Du einen MS SQL-Express Server im Einsatz hast. Ich versuche dies auch, scheitere aber kläglich. Auf meinem Entwicklungs-PC (WIN10 64) läuft ein "echter" 2014 MS SQL als Instance "localhost" und ein 2012 Express als Instance "localhost/SQLEXPRESS". Der 2014 verbindet sich problemlos und der 2012 will einfach nicht. Habs mit Servoy 8.14 und 8.20 versucht. Frage: ist die Url aus Deinem Beitrag noch aktuell ?

Danke und schöne Grüße
Roland

Gabriel

 Administrator

  • »Gabriel« ist der Autor dieses Themas

Beiträge: 199

Wohnort: Inwil LU (CH)

  • Private Nachricht senden

5

Dienstag, 12. September 2017, 07:39

Hallo Roland

Am Connection String hat sich nichts geändert, der stimmt immer noch so.

Prüfe mal im Management Studio mit 'select @@SERVERNAME' ob du alles richtig angegeben hast. Damit bekommst du 'Servername\Instanzname' zurück.


Evt. kann es daran liegen, dass du TCP für den Express nicht freigeschaltet hat.
Um das zu prüfen musst du den SQL-Server Konfigurations Manager starten. Wenn der nicht als Verknüpfung zur Verfügung steht musst du den über MMC öffnen.
Dazu MMC starten, dann Im Menü Datei die Option 'Snap-In hinzufügen/entfernen' wählen. Dann 'SQL Server Konfigurations-Manager' zufügen.
Danach die Baumstruktur aufklappen. Darin hat es unter anderem die Node 'SQL-Server Netzwerk Konfiguration'. Darin gibt es die Option 'TCP/IP' und die muss auf 'Aktiviert' stehen.
Gabriel

EWI

Anfänger

Beiträge: 80

Wohnort: Feldkirch, Vorarlberg, Österreich

  • Private Nachricht senden

6

Donnerstag, 14. September 2017, 10:37

Mssql$Sqlexpress

Hallo Gabriel,

Danke für Deine Antwort. TCP/IP ist aktiv und der Instancename dürfte auch stimmen. Was mich irritiert ist der Anmeldename MSSQL$SQLEXPRESS, verrenn ich mich da ?

SG Roland
»EWI« hat folgendes Bild angehängt:
  • MSSQL$EXPRESS.JPG

EWI

Anfänger

Beiträge: 80

Wohnort: Feldkirch, Vorarlberg, Österreich

  • Private Nachricht senden

7

Donnerstag, 14. September 2017, 17:45

Hallo Gabriel,

ich hab es nun rausgefunden: Du lagst richtig mit TCP, allerdings war es nicht die Aktivierung sondern die Einstellung auf Dynamische Ports (siehe Anhang). Nachdem ich auf 1433 fixiert habe, gehts :)

Nachmals Danke für Deine Hilfe und
SG Roland
»EWI« hat folgendes Bild angehängt:
  • MSSQL$EXPRESS_solved.JPG

Social Bookmarks

Thema bewerten