Du bist nicht angemeldet.

1

Donnerstag, 25. Juli 2013, 09:56

Solution Import hängt sich auf

Hallo zusammen

Ich habe ein Problem beim Importieren einer Solution auf einem Application-Server (das Problem ist offenbar sehr ähnlich wie jenes von Harro vom 31.07.2012 #mce_temp_url# Leider konnte ich es aber bei mir nicht lösen):

Wenn ich die Solution importieren will, so startet der Import zwar, aber es wird nie fertig (scheint irgenwie eine Endlosschleife zu sein). Ich kann auch nicht mehr im Servoy-Administrator auf die "Servoy Server Home"-Seite wechseln (die anderen Menus wie z.B. Clients, Solutions etc. funktionieren aber). Es bleibt mir nichts anderes übrig, als den Application-Server-Dienst neu zu starten.

Genau die selbe Solution (*.servoy-Datei) habe ich aber auf anderen Servern bereits erfolgreich eingespielt!!!

Bei den Servern, bei denen der Import erfolgreich verlief, handelt es sich um IBM-Cloud-Server mit Postgres-DB. Bei dem Server, bei welchem der Import nicht funktioniert, handelt es sich um einen lokalen Server und um einen SQL-Server als Backend.

Auf dem Server, bei welchem der Import nicht funktioniert, läuft aber bereits eine andere Solution (die offenbar erfolgreich importiert werden konnte). Auch jene Solution greift auf einen SQL-Server zurück.

Kann mir irgendjemand einen Tipp geben, wo das Problem liegen könnte? Gibt es irgend ein Log, welches man zu rate ziehen könnte (das Server-Log auf der Servoy-Admin-Page ist leer!!!).

Danke im voraus.

Gruss
Roli

2

Donnerstag, 25. Juli 2013, 16:44

Hi Roli

Welche Servoy Version? Ich glaube bei der Version 6.1.2 gab es mal ein Problem beim Einlesen von neuen Solutions. Nur das Updaten bestehender Solutions hat funktioniert.
Keine Ahnung ob es da eventuell einen Zusammenhang mit deinem Problem gibt.

Gruss
Oli

3

Donnerstag, 25. Juli 2013, 17:25

Hi Oli

Danke fürs Feedback.

Unsere Version ist die 6.1.5.

Gruss,
Roli

Gabriel

 Administrator

Beiträge: 199

Wohnort: Inwil LU (CH)

  • Private Nachricht senden

4

Montag, 12. August 2013, 16:32

Hi zusammen

Es scheint, dass die Ursache ein Style ist, welcher mit gleichem Namen in zwei verschiedenen Solutions verwendet wird.
Offensichtlich möchte der Import den Style überschreiben, dieser ist aber von der anderen Solution gelockt. Es ist auch nicht möglich, diesen Style manuell zu löschen.
Bleibt wohl nichts anderes, als für jede Solution eigene Styles zu führen, auch wenn diese identisch sind.
Gabriel

stefanoni

anhaltend neugierig

Beiträge: 273

Wohnort: CH-8200 Schaffhausen

  • Private Nachricht senden

5

Freitag, 30. August 2013, 15:26

hi,
ich verwende nur einen einzigen style für
alle modules und alle solutions und hatte noch
kein problem damit.

Es wäre doch mal interessant, den betreffenden
import in einen jungfräulich aufgestarteten server
zu machen.

gruss
Alessandro Stefanoni ---- gigdoodle.ch ---- stefanoni.ch ---- Stefanoni Informatik Gmbh, CH-8200 Schaffhausen Switzerland
(Servoy Version: 6.0.6 Win XP / 7, Postgres)

Social Bookmarks

Thema bewerten